Synology NAS Diskstation: Blauer LED Fehler

Wer eine Synology NAS sein eigen nennt, wird früher oder später auch einmal einen Ausfall erleben. Sei es das die gesamte NAS Einheit nicht mehr funktioniert oder nur die ein oder andere Festplatte ihren Geist aufgegeben hat.

Im folgenden Fall gab es jedoch den Teils bekannten Blue LED Fehler.
Die NAS, in unserem Beispiel eine RS2212+ Einheit, war im laufenden Betrieb noch per Ping erreichbar. Auch ein Zugriff auf das gemountete iSCSI Volume war noch möglich, jedoch meldete ein Monitoring-System, dass der Status dieser Einheit sich geändert hätte.

Beim Überprüfen über das Webinterface ging es schon nicht weiter.
Das Webinterface war nicht mehr verfügbar.
Auch der Login Bereich des Webinterfaces wurde erst gar nicht dargestellt.

Der SSH/Telnet Zugriff ist standardmäßig deaktiviert und konnte somit auch nicht auf der Synology NAS reaktiviert werden. Die Diskstation musste also manuell neu gestartet werden.

Normal fährt eine Synology NAS beim gedrückt halten des Power-Knopfes nach einem Beep-Ton automatisch herunter. In diesem Falle ging selbst das nicht mehr und man war gezwungen das NAS-System hart abzuschalten.

Blauer LED Fehler an einer Synology RS2212+

Beim Neustart des Systems ergab sich folgendes Bild.

Der Power Knopf blinkte dauerhaft Blau und die beiden LAN Port-LEDs zeigten Traffic an. Jedoch ertönte beim Starten nicht wie gewohnt nach einigen Minuten der Beep Ton, damit das System nun erfolgreich hochgefahren wurde. Auch alle LED’s an den Festplattenschächten blieben aus und zeigten keine Reaktion.

Fehlersuche an der Synology NAS

Die Fehlersuche ergab sich hier etwas schwierig, da keine Terminalsitzung zum Gerät aufgebaut werden konnte und auch kein Konsolen-Port Kabel verfügbar war. In den hiesigen Herstellerforen war bei diesem Verhalten immer die Rede von einem defekten Netzteil, einer defekten Festplatte oder gar dem Mainboard.

Um der Sache auf den Grund zu gehen, ging ich wie folgt vor. Zuerst trennte ich die NAS vom Strom und wartete ein paar Minuten. Danach zog ich alle Festplatten aus den Schächten und stellte die Spannungsversorgung wieder her. Nach einem Start ohne Festplatten kam jetzt zumindest die Status LED mit einem Fehler Beep zum Vorschein.

In diesem Status steckte ich dann die Festplatten wieder nacheinander in die Einschübe. Die LEDs der Festplatten leuchteten kurz auf, aber die NAS war weiterhin nicht über ihre IP erreichbar bzw. ging aus dem Fehlermodus raus.

Ein erneuter Neustart inkl. gesteckter Platten ergab wieder das Bild von Beginn. Eine blinkende blaue LED ohne Reaktion des Systems und ohne aktive LEDs an den Festplatteneinschüben.

Es musste also etwas mit den Festplatten zu tun haben. Im Nachgang wurden also jede Festplatte einzeln gesteckt und geschaut wie sich das System verhielt. Zum Glück reagiert das System gleich anders, als die Festplatte in Slot 1 gezogen wurde.

Nachdem die Festplatte in Slot 1 getauscht wurde, musste die NAS mittels des Synology Assistant Tools neu im Netzwerk gesucht und eingerichtet werden.

Diskstation Betriebssystem verloren

Warum fuhr das System aber nicht mehr hoch?

Die Ursache war, dass die Festplatte in Slot1 defekt war und hier das Betriebssystem der Synology Diskstation gespeichert ist. Auch wenn auf der NAS ein RAID eingerichtet wurde, bleibt weiterhin die Partition des Betriebssystems auf dieser einzelnen Festplatte. Fällt diese also mal aus, ist kein Zugriff mehr auf das Webinterface möglich und auch ein Neustart des Systems bringt keinen Bootvorgang mehr zustande.

Leider wurden hierdurch auch die LEDs der einzelnen Festplattenschächte nicht mehr angesteuert. Die Fehlersuche war hier also etwas knifflig.

Nachdem die NAS aber mittels Tool wieder eingerichtet und das aktuellste Betriebssystem installiert wurde, konnten auch die restlichen Platten auf SMART Fehler überprüft werden.

LED Fehler an einer Synology NAS DiskStation RS2212+

In diesem Falle waren leider mehr als nur die eine Festplatte defekt und das RAID 6 somit hinfällig.

Hier lohnt sich nur noch ein Neuaufbau des RAIDs und ein Rückspielen der Daten aus einer Sicherung.

Fazit

Es zeigt sich also das Synology hier mal nachjustieren sollte. Getestet wurde das ganze mit einer alten RS2212+. Ob sich das mit den neueren Synology NAS Systemen auch so verhält, kann ich also nicht beurteilen.

Ich würde es jedoch Begrüßen, wenn man das Betriebssystem von Haus aus schon auf mindestens 2 Platten im Copy Modus hinterlegen könnte und der Bootloader einfache immer Schacht 1 + 2 als Bootreihenfolge verwenden würde. Sollte hier also mal die Primäre Festplatte in Schacht 1 ausfallen, könnte der Bootloader von Schacht 2 booten.

Alternativ würde ich es auch Begrüßen, wenn man die Möglichkeit hätte das Betriebssystem nach dem erstellen eines RAIDs mit auf das RAID Volume zu verschieben.

Die Synlology NAS fährt nicht mehr hoch und das Webinterface ist nicht erreichbar. Hier die mögliche Lösung für das Problem
Speichere in deinen Favoriten diesen permalink.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.